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1 Details of Supplementary Information
This PDF contains a series of tutorials for the techniques outlined in the main paper, a flowchart outlining
the and the various choices that must be made, as well as some tables giving additional details of the
work performed. In addition to this there are a series of video tutorials showing these techniques being
performed. Finally, the final, successful versions of each 3D printing file is also availible in the ESI.

2 Detailed instructions for colour coding and exporting 3D printable files
from Mercury

The first step to printing crystallographic data is to convert the data from a crystallographic data file
to a 3D printing file. The main procedure we use for this is via Mercury, and that is the procedure we
outline here. This is due to the fact that, as far as we know, Mercury is the only crystallographic software
to support exporting colour information, which makes the cutting much easier in most cases. However,
there is nothing inherent in the connectors that demands the use of Mercury, so the export features of
Chimera or PyMol or other software can be used instead and coupled with the technique in Section 5.

This procedure is adapted from that used previously to print either ball and stick or ellipsoidal data
from Mercury.1,2

First open the CIF file in question in Mercury.
Second, alter the structure shown on screen to match what you want to print by hiding sections you

don’t want to print (hydrogen atoms, counterions, etc.) and generating parts you do want to print with
short contacts, hydrogen bonds, or specific contacts. How to expand a structure in this manner is beyond
the scope of this ESI, and will be familiar to people who have used Mercury before. However, it is advised
to do this as little as possible, as Mercury has a tendency to overlaying multiple cylinders on top of one
another for its bonds when you do this, which can make printing difficult. The better option, if possible,
is to click the “Packing” switch at the bottom of the screen and use the following instructions to edit down
your structure from that.

Remove any parts you do not want to print, either by using the Show/Hide→Hide Atoms right-click
command, or the Delete this Molecule right-click command. The structure to be printed must be one
continuous unit; that is, when it is finished printing it must be one single physical object: For example,
you can’t print two parts of a non-coordinating anion/cation pair, though you could export each piece to
a separate 3D printing file.
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Third, the structure must have physically meaningful dimensions for printing. Go to the Manage
Styles. . . drop down list and select the “3D print” setting (This assumes you want to use the default “3D
Print” style in Mercury, and that they have not been changed3).

Fourth, colour the atoms to separate them into the units you want to print. Note: This is much easier if
all the connectors are oriented into the same print plane, or perpendicular to the print plane. Another way
of thinking of this: Draw an imaginary cube around each subunit you plan on printing. Every connector
should be directly pointing at one of the faces if possible. If this is not possible, continue as normal,
placing as many of the connectors as possible to align with the print direction, and see Section 6. If
none of the connectors can be aligned in this manner, colouring the structure is unnecessary and can add
complications, as the cuts will be put in manually. Instead set the structure to be monocoloured, and
export the file as outlined below (either STL or WRL files can be used from here on since colour won’t
matter in this case), and consult section 6. Now colour the atoms you want to group into a subunit
the same colour. This can be done by selecting the atoms you wish to colour, then using the right-click
command Colours and then selecting the colour you desire. Note that the Lasso Atoms tool can make
selecting atoms much faster.

Finally, once you have all the subunits coloured as you desire, go to File→Print in 3D. . . . Set the file
format to “VRML (colour)”, the output directory to wherever you want the file saved and click print. A
Virtual Reality Markup Language (VRML, or *.WRL file) will be generated in that directory. Next use the
software of your choice to separate the coloured parts

3 Separating the parts into separate files
The next step in most structures is to separate the parts by colour so that you have two (or more) pieces
to add the connectors to.

There are two ways to separate the parts into colours. Most of the work for this paper was done with
Magics as outlined in Section 3.2, due to existing expertise with that software. However, due to the cost of
that software package serving as a potential limitation on the adoption of this technique, an investigation
was undertaken and it was found that the colour separation can be done just as well using MeshLab,
though MeshLab (Section 3.1) does not have the same features for repairing structural issues as Magics.
There are other tools to repair 3D printed files, though their use falls outside our area of expertise, and
given how rapidly this area is developing, we thought investigating this better left to the reader.

3.1 Procedure for using MeshLab to separate parts by colour

The open source and gratis software MeshLab from the Visual Computing Laboratory, the Istituto di
Scienza e Tecnologie dell’Informazione and the Consiglio Nazionale delle Ricerche can be used to separate
parts by colour. This procedure was tested with MeshLab_64bit_fp v2016.12.4

First, import the VRML file into MeshLab. Then use the Filters Menu, submenu Color Creation &
Processing [sic] and select Transfer Color: Face to Vertex [sic] and press Apply.

Then, for each coloured, section go to the Filters Menu, submenu Selection and select Select Faces by
Color [sic]. Click on the block of colour next to Color To Select [sic], which will open the “Pick a Color”
[sic] window. Click the Pick Screen Color [sic] button, and click on the specified subunit. If there are any
similar colours on the structure (such as red and orange), adjust the “Variation from” values downwards
to ensure that only the clicked colour is selected. Click Apply. If multiple colours are highlighted when
you click Apply, press the Default button and press Apply again to unselect everything (assuming you
didn’t use black as a colour, since it is the default. If you did, then find a colour totally unlike anything
you used and select that.) Adjust the “Variation from” values downwards and try again.
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Then open the Filters menu again, submenu Mesh Layer, and select Move selected faces to another layer.
This will create a new layer that can be separately saved to a STL or VRML file with the Export Mesh As. . .
command in the File menu.

3.2 Procedure for using Magics to separate parts by colour

This procedure is written for Materialise’s Magics (v19.0.1.11) and may need to be adapted to other
versions of the software.

First open your file: File→Import Part.
Second: Separate your part by colours: Tools→Split Part by Color [sic].
Third: Unload any parts you do not want to print by right clicking on the part and selecting the

“Unload Selected Parts” option (It looks like a green cube with a red x in the lower right hand corner. If
in doubt, a tooltip will pop up after a a second or two.)

Fourth: Save each part to the hard drive with a descriptive name. This procedure generates a lot of
similar files, and it is easy to confuse them. This is done by selecting the part you want and right-clicking
on it. The save icon looks like a 3.5′′ floppy disk with a green cube in the lower right hand corner. For
those who don’t know what a floppy disk is, it is the standard save icon with a green cube in the lower
right hand corner. There is a bug in this version of Magics that causes it to save everything in VRML files
as 100x smaller than they are. This can lead to detail being lost, and eventually the file will not load
correctly, due to the small size of the objects within it being approximated as zero. Therefore, after this
point, the authors use STL files to avoid this bug. VRML files do have a much smaller file size however,
and can be used if the structure is resized to be 100x larger before saving (Control-R to open the rescale
menu).

Fifth: Unload all but one part as the fixing commands only work on one part at a time.
Sixth: Go to Fixing→Fix Wizard or press Control-F. This opens the Fix Wizard. It should be noted that

this order of operations was developed and found to be reasonably reliable with structures imported from
Mercury.5 Run the Diagnostics tool by pressing Update with all the checkboxes except for “overlapping
triangles detected” and “intersecting triangles detected” checked. These two flaws have been found to
rarely impede successful printing and fixing them often leads to damage to the structure so they are
either ignored, or left until last. Ignore the suggested order and go to Shells, not Noise Shells, in the
right-hand menu. Select the Automatic Fixing option and inspect the damage to the structure. This will
work most of the time, as long the structure was not repaired before being separated into parts: however
it may not work for more complicated structures with overlapping bits. The various methods of fixing this
are somewhat beyond the scope of this tutorial, but I suggest playing around with the options, finding
small, almost non-existent, shells and removing them first, then try automatic fixing again. Either way,
after every fix, examine the structure for damage and use the undo command if there is any damage
(Control-Z, the same as in a word processor). If that doesn’t work, try playing around with the other fixes.
Go back to the diagnostics page and update the list of errors. The automatic fixing of the shells should
have removed most or all of the remaining errors. Go through any remaining flaws starting with Normals
one by one, again checking for damage to the structure each time. At this point you might as well try the
“overlapping triangles detected” and “intersecting triangles detected” options, though be careful, as they
often lead to damage to the structure. Once the structure is fully repaired, save it as a new file, again, as
either an STL or VRML but avoiding the shrink by a factor of 100 VRML bug if it is present in your version
of the software. Close this part, open the next part you wish to print, and repair it in the same manner.
Repeat this for each part, then move on to importing them into the CAD editor of your choice to add the
pegs and slots.
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4 Adding connectors to the parts using Solidworks
Now that the structure has been separated into multiple parts, the connectors can be added.

These instructions are a general outline, rather than the more specific steps for Meshlab and Magics.
This is due to the fact that there is a wide variety of CAD software available that could be used for this
step, and there are likely more efficient ways to reach the same results. Additionally, a large number of
closely related tasks must be done, and it would be impractical to list every one step by step. However, to
aid in demonstrating this task, several video tutorials have been included to help illustrate the steps.

4.1 A simple square connector

Open the STL or VRML structure in Solidworks and make sure it imported as a solid and not a surface. If
it imported as a surface, the repair features can usually be used to correct this. Sometimes you will need
to re-export it from Mercury as the other type of file format, or scale the file to twice or half size to get
Solidworks to accept it as a solid and not a surface.

Then a sketch must be placed on the flat surface of the face of the bond. In the best case scenario, the
face will be a single surface and have the centre of that surface at 0,0 or marked with a point. In this case,
use that point as the centre of your connector. If none of these things are true, see subsection 4.2 for the
workaround.

Once you have your centre point, use that as a basis for a square of appropriate size. Now go to the
Features tab and use either the Extruding Boss/Base (for a peg) or Extruded Cut (for a slot).

(1a) The primary square without anything removed: It has 4-fold rota-
tional symmetry.

(1b) Draw two lines connecting the midpoints of the opposite sides of
the primary square. Now you have the centre of the square marked.

4.2 If Solidworks does not provide you with a clean surface or does not mark the centre
point

This section details several complications that you may come across while using Solidworks. It is hard to
explain these problems if you haven’t encountered them, so they are demonstrated in the attached video
tutorials.

If the centre point is not marked (most of the time), it can be located using the line tool. The software
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uses polygons to approximate cylinders, thus leading to the faces at the end of the bond being polygons
instead of circles. Use the line tool to draw lines between opposite vertices of the polygon until you have
determined the centre of the polygon. Then use the point tool to mark the centre of the surface and draw
the connector based on that. If you get an ugly mess of intersecting shapes, simply ignore it. Most of the
time it will not impact the sketch. If inserting a slot into that surface leaves a remnant, simply trace the
relevant portion of the connector onto the problematic surface and add another slot on that surface.

4.3 Removing rotational symmetry

As outlined in the paper, when assembling structures it is convenient to remove rotational symmetry from
the connectors to avoid errors when assembling the structure. However, this can lead to errors during the
design stage, which are harder to fix, though we hope software support will remove this problem.

This design of rotational-symmetry free connectors is created by ‘subtracting’ squares from the main
shape to form the connector into the desired shape. There are two ways to do this.

One is to manually determine an appropriate size and draw a square of that size starting at the corner
of the connector. This works quite well if the sides of the primary square forming the connector are an
even integer value, and the direction of the connector matches the natural way Solidworks wishes to align
your square.

If neither of these are the case (for example, if you want to use a connector for which the primary
square has a side of 3.141 mm, or if you are finding it difficult to draw a square in that orientation using
Solidworks) there is a simple method to place consistently sized squares within your primary square.
Solidworks will let you attach lines to the midpoints of other lines, and this can be used to divide your
connector up into smaller squares. This technique is demonstrated in Figures 1a through 3b.

5 Using Solidworks to cut structures at arbitrary points

If the software you are using (such as Chimera or PyMol) does not output coloured files, then Solidworks
can be used to cut them at arbitrary points. As shown in Section 6, this can also be used to help with the
printing of troublesome structures that don’t have a way of aligning the bonds with or parallel to the print
try.

To do this, first make one of the reference planes (“Front Plane”, “Top Plane”, and “Right Plane” in
the left-hand tree) visible. This is done by right clicking on the plane and selecting the appropriate option
from the popup menu.

While there is not a specific video tutorial for this, it is shown as part of the video tutorial for adding
connectors to structures whose bonds do not align with the print tray.

Go to the Features menu →Reference Geometry to add a plane at the appropriate point. The easiest
way to do this is to offset the new plane from one of the reference planes (and this is the only way the
authors done it), but it is possible to use up to three reference items to position the plane exactly as you
wish.

Select your new plane, then select Insert →Cut →With Surface. Select the direction you wish to delete.
If this leaves more than one unconnected object, you will get a popup asking which to save. Select the
one you want and save it. Then press the undo button (or press control-Z if on Windows), and repeat the
cut, but this time save the other object. You now have two files, each with one of the objects you need to
add a connector to.

This description may have to be adapted to more complex situations, such as that shown in Section 6,
but the general principles are the same.
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(2a) You also have divided the square into quarters. This will let you
use the Trim Entities tool to remove the walls of the primary square
to make an L-shaped connector. If you require more complicated
connectors, draw lines from the midpoint of the sides of the primary
square to the centre, overlapping the lines you just drew. This will let
you repeat this process, by using the midpoints of these new lines to
further subdivide the squares. In this diagram the lines connecting
one side to the other have been removed to highlight the new lines,
but this is not needed in normal practice.

(2b) If a connector other then the basic L shape is needed, this pro-
cess can be repeated. Divide the quadrants of the primary square
themselves into quadrants using the midpoints of the lines drawn in
Figure 2a.

6 Printing structures whose bonds do not align with the print tray
While this does not seem necessary for printing with commercial print services such as Shapeways (based
on very limited testing, please don’t discover this isn’t true in a way that costs you a lot of money), with
the printers we have access to, we have found that the connector must be either parallel or perpendic-
ular to the print tray, or the slot and peg deform. This is relatively easy with most d-block complexes
(octahedral and square planer geometries lend themselves to this quite well), MOFs that have cubic unit
arrangements, polymers that contain aromatic rings and similar. However, complex natural products,
main body compounds, minerals, more geometrically complex MOFs such as the UiO series, and f-block
compounds often have geometries that do not lend themselves to right-angled alignments. To get around
this, we have developed a technique that does not require bonds to be cut perpendicular to the bond
angle. While it has some drawbacks, , including requiring more labour and sometimes the use of glue, it
produces a robust and pleasing final product.

This explanation is rather complicated, and possibly best explained by the video tutorial also included
as part of the electronic supplementary information for this paper. However, a best effort has been made
to outline the broad strokes of the procedure using Solidworks, trusting that the general method can be
adapted to the software of the user’s choice. This section will make heavy use of the technique outlined
in 5.

The general principle is to use planes to cut through the bonds so that all the connectors are at a good
angle for printing. This means that the angles of the connectors will no longer be perpendicular to the
angles of the bonds. I will be using RaF2, which adopts the fluorite structure, as an example, and thus
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(3a) Now you can remove sixteenths with the the Trim Entities tool
until you have an appropriate shape. You could further subdivide the
sixteenths, but that would be too small to print at the sizes and with
the printers our tests have been done with.

(3b) You will need to remove unneeded lines until Solidworks shades
the interior (Compare the blue shading in this figure with the lack of
shading in 3a). Then the Extruding Boss/Base or Extruded Cut tool
can be used to add the desired peg or slot.

Figure 4 Diagram of placing the planes around radium in RaF2. Note the planes are equidistant from the centre of the radium
atom.

will have an atom as the centre of my printable unit. However, this technique could be done with larger
assemblies as well, with molecules, moieties, or proteins.

To start, create a plane bisecting the bonds on one side of the atom or molecule in question. In
a symmetric system such as RaF2 you will then want to place a plane on the other side of the atom,
molecule or moiety in question, equidistant from the centre, so that the bonds are cut to the same length.
In asymmetric systems, you don’t have to worry about keeping the bonds the same length.

Now place similar planes around the other object. You will likely have a gap between the two, as
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Figure 5 Only four of these planes are needed for cuts: The other serves as a reference. The square is used to measure the
distance from the centre of the fluorine atom. Note that since the bonds do not extend far enough, it is not possible to get a clean
cut on all the bonds with a single plane between the radium and fluorine. A spacer was used for this reason.

shown in Figure 5. Lines or squares can be used to ensure the planes are equidistant from the centre of
the object in question.

Figure 6 Using a large square centred at the origin as a reference point.

Now cut along the plane as outlined in Section 5. Save each object as a separate file, including one
for the spacer.

Now the more complicated part is adding a connector to each of these parts such that they perfectly
match. This is done as in Section 4; however, it is complicated by the fact that the surfaces you are
placing the connectors on will not be circles, but ellipses. There is one trait of Solidworks that we can take
advantage of: since all three parts were formed from one file, they share an identical coordinate system.
Therefore, the authors can draw a big square on the plane used to form the cut, centred at the origin.
Then the authors place each connector at a fixed distance from the closest two walls, and they will be
at the same point. For example, draw an x by x square, and place each connector in the centre of each
quadrant. Then you can draw the same square on the next part, and place the connectors in the same
place.

However, note that you have to make sure the centre of each connector is located at the same place,
and not the corners. For example, in Figure 6 the lower right corner is used as the reference point, which
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(7a) The results of aligning both the peg and slot to the same corner. (7b) It is not hard to properly centre a square within another square, to
correct for a corner used as a reference point.

if used for both the slot and peg would result in the situation shown in Figure 7a. If both the peg and the
slot are aligned in this way, there will be too much clearance along two sides, and none along the other
two. This can be avoided, even if the corner is the simpler reference point, by aligning an identical square,
then placing the centre of the peg at the centre of the slot.

Since this method places multiple objects to be extruded6 on the same sketch, all of them must be
extruded at the same time. This can be done by starting to extrude one as normal, then holding down
shift and clicking each other part of the sketch to be extruded. The only limitation to this I have found is
that it limits you to all pegs or all slots at once. This means that you’ll have to create a second sketch on
the same plane if you want to mix pegs and slots on the same side of the part.

Since the coordinate system is shared by all three parts, it is valuable to use the Make Assembly feature
(under “File” →“Make Assembly From Part. . . ”) to check your work. Add all the parts to the assembly
(“Assembly” panel, “Insert Components”), to make sure they align properly. Then use the “Interference
Detection” feature (Under the “Evaluate” menu) to check that all of your pegs fit into your slots.

7 Details of Experiments and Tools Used

Table 1 Summary of Software Used

Software Version Creator Licence

Mercury Multiple versions Cambridge Crystallographic Data Centre Gratis–Closed Source
Magics v19.0.1.11 Materialise Commercial

Solidworks Educational Edition Dassault Systèmes Commercial
(Academic Year 2017–2018/2017 SP3.0

MeshLab MeshLab_64bit_fp v2016.12 Visual Computing Laboratory, Free (GPL3.0)
Istituto di Scienza e Tecnologie dell’Informazione
and the Consiglio Nazionale delle Ricerche

ZEdit Pro v1.1 Z Corporation Commercial
Insight v10.6 Build 4739 Stratasys Commercial
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Table 2 Index of structures printed

Part Print location Printer Plastic

Copper Pyrazine Dicyanoaurate
Au(CN)2

α

White Shapeways Unknown Versatile Plastic—Natural Finish
Red Shapeways Unknown Versatile Plastic—Processed Finish
Gray [sic] Shapeways Unknown Professional Plastic—Standard Finish
Black Shapeways Unknown Professional Plastic—Standard Finish
Translucent Shapeways Unknown Fine Detail Plastic—Smooth Finish
Bronzed-Silver Shapeways Unknown Steel—Polished Finish
Bronze Shapeways Unknown Steel—Polished Finish
Blue Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support

Copper Pyrazineα

White Shapeways Unknown Versatile Plastic—Natural Finish
White Shapeways Unknown Fine Detail Plastic—Smooth Finish
Blue Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support

Entire Repeat Unitβ Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support
Entire Networkγ Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support

Sodium Chloride Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support
Sodium Chlorideδ Private Individual Ender 3 Value PLA 1.75 Yellow
NaCl with failed connector shapes

Triangular connectors Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support
Merged Circular connectors Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support
Squares unaligned to plane Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support

RaF2
ε Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support

RaF2
ε SFU Engineering Stratasys Fortus 250mc ABSplus P430 and SR-30 Support

Phthalocyanineζ Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support
Phthalocyanineζ ,η Document Solutions Stratasys Fortus 250mc ABSplus P430 and SR-30 Support
α Mistake in rotation of the connectors prevented construction of a repeating structure.
β Unknown flaw in structure led to failed prints twice, despite repairing the structure with all software available.

This is unrelated to the main techniques outlined in the paper, as it isn’t near any of the connectors.
γ Network printed in a distorted manner due to problem with heating sensor.

Before photography, network was knocked off the shelf and broke. It snapped several more times during repairs.
It was eventually glued back into suitable condition for photography, though the distortion could not be corrected.

δ Printed and assembled by an secondary school student.
ε These two print runs were combined into one model.

This was the only structure in which glue was needed to hold the connectors together.
ζ The ligands are slightly incorrect. The two THF ligands should be mirror images of one another.

However, the author decided to create this structure while recording a demonstration.
As a result, this symmetry operation was not noticed, and a single THF was printed twice.

η A communication error resulted in a print run where the model was printed unaligned to the tray.
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8 Flow charts outlining procedures
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Figure 8 Flowchart aligning what software is needed in what order.
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Figure 9 Flowchart aligning what connectors should be used.
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9 Other print runs not featured in the paper

Figure 10 In addition to being too heavy to use, the metal parts from Shapeways came out a slightly different size and would
not connect to the plastic parts. However, the cuts were nice and crisp, so we suspect that a totally metal print run should be
possible, though budget constraints prevented us from testing this hypothesis.

Figure 11 A failed attempt to remove symmetry using cuts at a 45-degree angle.
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Figure 12 Despite being printed on the same model printer, note the difference between this and the other image of a slot. In this
case the item was printed line by line: In the ones printed with SFU physics a more vector approach was obviously used. Despite
this both parts where compatible and combined into a single object.
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[5] However, while preparing this manuscript, a structure exported from PyMol was fixed for a colleague
working on an otherwise unrelated project, and it was found to need a different sequence of repairs.
Therefore, even more than the rest of these instructions, this section should be taken as guidelines
that worked for us, and other combinations of software and structure may need a different order of
repairs or manual tweaking to render them watertight and printable.

[6] This is the terminology Solidworks uses, not to be confused with the physical extrusion process used
in 3D printing.
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