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S1 Image analysis
The images of deformed Giant Unilamellar Vesicles (GUVs) were extracted from the study published by Maoyafikuddin
et al. (2025)1. These images were analyzed using ImageJ software. Initially, the outlines of the deformed GUVs were
drawn using the freehand selection tool in ImageJ, and the selections were added to the Region of Interest (ROI) manager.
To determine the centroid of each ROI, the following steps were taken: Navigate to Analyze > Set Measurements, select
the ’Centroid’ option, and click ’OK’. Select the ROI, then go to Analyze > Measure; a window will pop up displaying
the centroid coordinates. Subsequently, the origin was redefined to align with the centroid coordinates by accessing
’Edit > Selection > Properties’ and inputting the centroid’s X and Y values as the new origin for the selected ROI. This
adjustment ensures that the extracted coordinates are referenced from the centroid. After setting the new origin, the ROI’s
coordinates were extracted by selecting ’List Coordinates’ in Imagej> Edit> Selection > Properties dialogue. For scenarios
requiring the extraction of a specific number of coordinates or integration with Python-based analyses, a custom macro
was developed to retrieve the coordinates and format them as a NumPy array.
// Define origin offset if necessary (set to 0 if not needed) x0 = 39.829; y0 = 42.344;

// Get ROI coordinates getSelectionCoordinates(x, y); n = x.length; desiredPoints = 500
// Create strings for NumPy arrays xString = ”xex = np.array([”;yString = ”yex = np.array([”;
// Loop over desired points and interpolate linearly between ROI points for (i = 0; i < desiredPoints; i++) u = i * (n

/ desiredPoints); idx1 = floor(u); idx2 = (idx1 + 1) t = u - idx1;
// Linear interpolation, then adjust by subtracting origin offset if needed xi = (1 - t) * x[idx1] + t * x[idx2] - x0; yi =

(1 - t) * y[idx1] + t * y[idx2] - y0;
// Append to strings with proper formatting if(i < desiredPoints - 1) xString += " " + xi + ", "; yString += " " + yi +

", "; else xString += " " + xi; yString += " " + yi; xString += "])"; yString += "])"; // Print the NumPy array formatted
strings print(xString); print(""); print(yString);

After extracting the coordinates of the deformed Giant Unilamellar Vesicles (GUVs) using ImageJ, the radial deforma-
tion parameters were determined by fitting the experimental data to a theoretical model. This involved minimizing the
difference between the experimentally obtained radial distances and those predicted by the following equation:

r(θ) = r+S2 ·
3cos2 θ −1

2
+S4 ·

3−30cos2 θ +35cos4 θ

8
+S6 ·

−5+105cos2 θ −315cos4 θ +231cos6 θ

16

Here, r(θ) represents the normal radial distance of the membrane surface at angle θ , r is the normalised radius, and S2,
S4, and S6 are deformation coefficients respectively. The optimisation was performed using Python’s numerical libraries
to minimise the radial distance between the experimental and theoretical coordinates, thereby accurately determining the
values of r, S2, S4, and S6 for available experimental deform images.

Figures S1,S2,S3, and S4 show the coordinated extraction of deformed shapes (blue continuous) and the theoretically
fitted shape (red circle).
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(a) (b)

(c) (d)

Fig. S1 Experimental coordinates of images of deform vesicles (red circle) and fitted theoretical shapes (blue continuous lines)

are shown for the four cases of β < 1.

1–22 | 2



(a) (b)

(c) (d)

Fig. S2 Experimental coordinates of images of deformed vesicles (red circle) and fitted theoretical shapes (blue continuous lines)

are shown for the four cases of β > 1.
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(a) (b)

(c) (d)

Fig. S3 Experimental coordinates of deform images of deform vesicles (red circle) and fitted theoretical shapes (blue continuous

lines) are shown for the four cases of β = 1.
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(a) (b)

(c) (d)

Fig. S4 Experimental coordinates of images of a deformed vesicle (red circle) and fitted theoretical shapes (blue continuous

lines) are shown for the cases in figure 3A of Karin A. Riske and Rumiana Dimova (2006)2. Tubelike deformation of a vesicle

of R = 24.1 µm at conductivity conditions β = 1.38, σin = 16.5 µS/cm, σout = 12 µS/cm, cin = 0.1 mM NaCl, and cout =

0.05 mM NaCl. The pulse parameters are E = 2 kV/cm and tp = 200 µs. Adapted from Riske and Rumiana Dimova (2006)2.

S2 Validation of results of Salipante and Vlahovska
We validate the code for the non-conducting membrane, Ge(t) = 0, and use the data for the two-pulse protocol suggested
by Salipante and Vlahovska3 in their figure 9. The oblate shape at the end of the short strong pulse and the prolate shape
at long times, during the extended weak pulse, as predicted by the entropic model for the unporated vesicle, are shown,
together with the variation of AR vs time. The variation of TMP and shape parameters with time are provided. Good
agreement is observed between the prediction of our code and the data presented in3.
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(a) AR vs time, showing oblate deformation followed by re-

covery to prolate shape

(b) Shapes at t=0µs black dot dashed, t=10 µs blue

dashed, t=50 ms red solid.

(c) TMP (Vm) vs time (d) S2 vs time

Fig. S5 Validation of Salipante and Vlahovska3 (Figure 9a) by the present model: Ro = 20.2 µm, Cm = 0.007 F/m2, σin =

2 µS/cm, σex = 10 µS/cm, γini = 4× 10−7 N/m. Showing oblate deformation at the end of short pulse (10 µs) and prolate

deformation at the end long pulse (50 ms). The oblate shape at the end of the short strong pulse and the prolate shape at long

times, during the extended weak pulse, as predicted by the entropic model for the unporated vesicle, are shown, together with

the variation of AR vs time. The variation of TMP and shape parameters with time.
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(a) β < 1

(b) β = 1

(c) β > 1

Fig. S6 The fractional pore area data plotted with parameters in using the electroporation model. 1 kV/cm, low salt- solid line

(red), 1.5 kV/cm, low salt- dashed (blue), 1 kV/cm, high salt- dot dashed (black), and 1.5 kV/cm, high salt- dotted (green) in

all three cases (a) β < 1, (b) β = 1, and (c) β > 1.
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(a) (b)

(c) (d)

(e) (f)

(g) (h)

Fig. S7 Plots for β < 1, low salt: First column E=1 kV/cm, unporated, second column E=1 kV/cm, porated. (a) and (b)

γentropic and γenthal py vs t plot, (c) and (d) Capillary stress due to non uniform tension ( fγnu) vs t, (e) and (f) Bending stress vs

θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (g), and (h) Non Uniform tension (τe
n) vs θ , t = τc/2-red

solid, t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b) (c)

(d) (e) (f)

(g) (h) (i)

(j) (k)

Fig. S8 Plots for β < 1, low salt, E=1.5 kV/cm, porated: (a) AR vs t plot, (b) Vmb vs t, (c) Vmb vs θ , t = τc/2-red solid,

t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Normal electric stress (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed,

t = tp-black dotdashed, (e) Tangential electric stress (τe
t ) vs θ , t = τc/2-red Solid, t = 1.5τc-blue dashed, t = tp-black dotdashed,

(f) s2,s4,s6 vs t, electric field directed from left to right, s2-red solid, s4-blue dashed, s6-black dotdashed, (g) r vs z circle- black

dotdashed, model prediction-red solid, experimental - blue dots (h) γenthal py vs t plot, (i) Capillary stress due to non uniform

tension ( fγnu) vs t, (j) Bending stress vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (k) Non Uniform

tension (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b)

(c) (d)

Fig. S9 Plots for β < 1, high salt, E=1 kV/cm, porated: (a) γenthal py vs t plot, (b) Capillary stress due to non uniform

tension ( fγnu) vs t, (c) Bending stress vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Non Uniform

tension (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b) (c)

(d) (e) (f)

(g) (h) (i)

(j) (k)

Fig. S10 Plots for β < 1, high salt, E= 1.5 kV/cm, porated:(a) AR vs t plot, (b) Vmb vs t, (c) Vmb vs θ , t = τc/2-red solid,

t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Normal electric stress (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed,

t = tp-black dotdashed, (e) Tangential electric stress (τe
t ) vs θ , t = τc/2-red Solid, t = 1.5τc-blue dashed, t = tp-black dotdashed,

(f) s2,s4,s6 vs t, s2-red solid, s4-blue dashed, s6-black dotdashed, (g) r vs z circle- black dotdashed, model prediction-red solid,

experimental - blue dots (h) γenthal py vs t plot, (i) Capillary stress due to non uniform tension ( fγnu) vs t, (j) Bending stress

vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (k) Non Uniform tension (τe
n) vs θ , t = τc/2-red solid,

t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b)

(c) (d)

(e) (f)

(g) (h)

Fig. S11 Plots for β = 1, low salt: First column E=1 kV/cm, unporated, second column E=1 kV/cm, porated. (a) and (b)

γentropic and γenthal py vs t plot, (c) and (d) Capillary stress due to non uniform tension ( fγnu) vs t, (e) and (f) Bending stress vs

θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (g), and (h) Non Uniform tension (τe
n) vs θ , t = τc/2-red

solid, t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b) (c)

(d) (e) (f)

(g) (h) (i)

(j) (k)

Fig. S12 Plots for β = 1, low salt, E=1.5 kV/cm, porated: (a) AR vs t plot, (b) Vmb vs t, (c) Vmb vs θ , t = τc/2-red solid,

t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Normal electric stress (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed,

t = tp-black dotdashed, (e) Tangential electric stress (τe
t ) vs θ , t = τc/2-red Solid, t = 1.5τc-blue dashed, t = tp-black dotdashed,

(f) s2,s4,s6 vs t, electric field directed from left to right, s2-red solid, s4-blue dashed, s6-black dotdashed, (g) r vs z circle- black

dotdashed, model prediction-red solid, experimental - blue dots (h) γenthal py vs t plot, (i) Capillary stress due to non uniform

tension ( fγnu) vs t, (j) Bending stress vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (k) Non Uniform

tension (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed, t = tp-black dotdashed. 1–22 | 13



(a) (b)

(c) (d)

Fig. S13 Plots for β = 1, high salt, E=1 kV/cm, porated: (a) γenthal py vs t plot, (b) Capillary stress due to non uniform

tension ( fγnu) vs t, (c) Bending stress vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Non Uniform

tension (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b) (c)

(d) (e) (f)

(g) (h) (i)

(j) (k)

Fig. S14 Plots for β = 1, high salt, E= 1.5 kV/cm, porated: (a) AR vs t plot, (b) Vmb vs t, (c) Vmb vs θ , t = τc/2-red solid,

t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Normal electric stress (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed,

t = tp-black dotdashed, (e) Tangential electric stress (τe
t ) vs θ , t = τc/2-red Solid, t = 1.5τc-blue dashed, t = tp-black dotdashed,

(f) s2,s4,s6 vs t, s2-red solid, s4-blue dashed, s6-black dotdashed, (g) r vs z circle- black dotdashed, model prediction-red solid,

experimental - blue dots (h) γenthal py vs t plot, (i) Capillary stress due to non uniform tension ( fγnu) vs t, (j) Bending stress

vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (k) Non Uniform tension (τe
n) vs θ , t = τc/2-red solid,

t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b)

(c) (d)

(e) (f)

(g) (h)

Fig. S15 Plots for β > 1, low salt: First column E=1 kV/cm, unporated, second column E=1 kV/cm, porated. (a) and (b)

γentropic and γenthal py vs t plot, (c) and (d) Capillary stress due to non uniform tension ( fγnu) vs t, (e) and (f) Bending stress vs

θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (g), and (h) Non Uniform tension (τe
n) vs θ , t = τc/2-red

solid, t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b) (c)

(d) (e) (f)

(g) (h) (i)

(j) (k)

Fig. S16 Plots for β > 1, low salt, E=1.5 kV/cm, porated: (a) AR vs t plot, (b) Vmb vs t, (c) Vmb vs θ , t = τc/2-red solid,

t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Normal electric stress (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed,

t = tp-black dotdashed, (e) Tangential electric stress (τe
t ) vs θ , t = τc/2-red Solid, t = 1.5τc-blue dashed, t = tp-black dotdashed,

(f) s2,s4,s6 vs t, s2-red solid, s4-blue dashed, s6-black dotdashed, (g) r vs z circle- black dotdashed, model prediction-red solid,

experimental - blue dots (h) γenthal py vs t plot, (i) Capillary stress due to non uniform tension ( fγnu) vs t, (j) Bending stress

vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (k) Non Uniform tension (τe
n) vs θ , t = τc/2-red solid,

t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b)

(c) (d)

Fig. S17 Plots for β > 1, high salt, E=1 kV/cm, porated: (a) γenthal py vs t plot, (b) Capillary stress due to non uniform

tension ( fγnu) vs t, (c) Bending stress vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Non Uniform

tension (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed, t = tp-black dotdashed.
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(a) (b) (c)

(d) (e) (f)

(g) (h) (i)

(j) (k)

Fig. S18 Plots for β > 1, high salt, E=1.5 kV/cm, porated: (a) AR vs t plot, (b) Vmb vs t, (c) Vmb vs θ , t = τc/2-red solid,

t = 1.5τc-blue dashed, t = tp-black dotdashed, (d) Normal electric stress (τe
n) vs θ , t = τc/2-red solid, t = 1.5τc -blue dashed,

t = tp-black dotdashed, (e) Tangential electric stress (τe
t ) vs θ , t = τc/2-red Solid, t = 1.5τc-blue dashed, t = tp-black dotdashed,

(f) s2,s4,s6 vs t, s2-red solid, s4-blue dashed, s6-black dotdashed, (g) r vs z circle- black dotdashed, model prediction-red solid,

experimental - blue dots, (h) γenthal py vs t plot, (i) Capillary stress due to non uniform tension ( fγnu) vs t, (j) Bending stress

vs θ , t = τc/2-red solid, t = 1.5τc-blue dashed, t = tp-black dotdashed, (k) Non Uniform tension (τe
n) vs θ , t = τc/2-red solid,

t = 1.5τc -blue dashed, t = tp-black dotdashed.
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Unporated 1 kV/cm (low salt) Porated 1 kV/cm (low salt) Porated 1 kV/cm (high salt)

(a) (b) (c)

(d) (e) (f)

Fig. S19 Electric field (V/m) distribution for β = 1, (a) and (d) 1kv unporated, (b) and (e) 1 kV/cm porated, all at low salt

(c) and (f) 1 kV/cm porated at high salt (first-row at t = τc, second-row at t = tp). Electric field in the direction of the arrow

(bottom to top).

1–22 | 20



Unporated 1 kV/cm (low salt) Porated 1 kV/cm (low salt) Porated 1 kV/cm (high salt)

(a) (b) (c)

(d) (e) (f)

Fig. S20 Electric field (V/m) distribution for β > 1, (a) and (d) 1 kV/cm unporated, (b) and (e) 1 kV/cm porated, all at low

salt (c) and (f) 1 kV/cm porated at high salt (first-row at t = τc, second-row at t = tp). Electric field in the direction of the

arrow (bottom to top).
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